Webmail Accessibility Issues
Incident Report for Hostinger
Resolved
We've resolved the issue and apologize for any inconvenience it may have caused.
Posted Mar 22, 2024 - 06:05 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 22, 2024 - 05:04 UTC
Monitoring
A fix has been put in place, and we're monitoring for any recurrence.
Posted Mar 22, 2024 - 04:31 UTC
Identified
Our investigation has led us to identify the issue.
Posted Mar 22, 2024 - 04:26 UTC
Investigating
Part of Hostinger Mail accounts may experience errors while accessing Webmail itself. Please note, that no emails will be lost during delivery and regular mail functionality will be restored in a timely manner. Thank you for being so patient.
Posted Mar 22, 2024 - 03:51 UTC
This incident affected: Email Hosting services (Hostinger Mail, Hostinger Webmail).