Hostinger payments maintenance
Incident Report for Hostinger
Resolved
The Hostinger payment server maintenance has been finished.
Posted Dec 27, 2019 - 18:19 UTC
Identified
We are currently experiencing main Hostinger payment server workflow interruptions and it may be inaccessible or not working as expected in the meantime. We apologize for any inconveniences. Thank You for the patience.
Posted Dec 27, 2019 - 17:19 UTC