Free mail service maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Mar 30, 2020 - 20:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 30, 2020 - 18:10 UTC
Investigating
We are performing Free Mail service maintenance. Clients will experience from 30 to 90 minutes long service interruptions while using Hostinger Free Mail services.
Apologies for any inconvenience. Thank you for your patience.
Posted Mar 30, 2020 - 13:27 UTC