Emergency NL-291 Server Maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Sep 15, 2021 - 15:59 UTC
Investigating
We are performing emergency server NL-291 maintenance. We will provide further updates as necessary.
Posted Sep 15, 2021 - 15:51 UTC
This incident affected: Hostinger Cloud Hosting (nl-srv-web291.main-hosting.eu).