hPanel email section maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Oct 06, 2020 - 12:01 UTC
Investigating
We are currently performing maintenance on email accounts management page in hPanel. Some clients may experience service interruptions while trying to manage their email accounts using hPanel interface.
Apologies for any inconveniences. Thank you for your patience.
Posted Oct 06, 2020 - 11:34 UTC
This incident affected: Core Services (Hostinger hPanel Frontend).