Free Mail - new mailboxes creation maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Aug 05, 2020 - 05:35 UTC
Investigating
We are currently performing maintenance on new email accounts creation on Free Mail services. Apologies for any inconvenience. Thank you for your patience
Posted Aug 05, 2020 - 01:17 UTC