Hostinger panel maintenance
Incident Report for Hostinger
Resolved
hPanel maintenance has been finished.
Posted Dec 27, 2019 - 17:18 UTC
Identified
We are currently experiencing main Hostinger panel workflow interruptions and it may be inaccessible or not working as expected meantime. We apologize for any inconveniences. Thank You for the patience.
Posted Dec 27, 2019 - 16:49 UTC