Datacenter Maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Sep 18, 2020 - 03:06 UTC
Investigating
US datacenter server is under maintenance. Client websites, control panel, and Hostinger websites can be inaccessible. We will provide further updates as necessary.
Posted Sep 18, 2020 - 02:17 UTC
This incident affected: Datacenters (US Datacenter).