Hostinger panel maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted May 20, 2020 - 10:32 UTC
Identified
There is currently an issue with hPanel not being loaded properly. The issue is known and should be resolved shortly. Thank You for your patience.
Posted May 20, 2020 - 08:58 UTC