Hostinger panel maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Mar 27, 2020 - 18:16 UTC
Identified
There is currently an issue with hPanel not being loaded properly. The issue is known and should be resolved shortly. Thank You for your patience.
Posted Mar 27, 2020 - 16:14 UTC