hPanel internal email service maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Mar 26, 2020 - 17:15 UTC
Identified
We’re currently experiencing a temporary issue with our internal email service. Password reminders, 2FA authentication emails might be affected. We are diligently working to restore normal operations as soon as possible.
Posted Mar 26, 2020 - 14:17 UTC