extended maintenance of us271
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Mar 03, 2021 - 07:45 UTC
Investigating
We are performing extened hardware maintenance on Server 271 in US. It’s crucial to ensure the continued upkeep and performance of your service. We will provide further updates as necessary. Thank you for your patience.
Posted Mar 03, 2021 - 07:37 UTC