Server SG-347 & SG-209 Maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted May 05, 2021 - 02:58 UTC
Investigating
We are performing unscheduled server maintenance. Clients may experience service interruptions. We will provide further updates as necessary.
Posted May 05, 2021 - 01:48 UTC