Server US-911 Maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 06:15 UTC
Investigating
We're performing testing server maintenance.
Posted Jun 02, 2021 - 11:02 UTC
This incident affected: Hostinger Cloud Hosting (us-gcp1-web911.main-hosting.eu).