Mail Service Maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Apr 07, 2021 - 15:51 UTC
Investigating
We are performing scheduled Mail service maintenance. Clients will experience from 30 to 60 minutes long service interruptions. We will provide further updates as necessary. Thank You for Your patience.
Posted Apr 07, 2021 - 14:12 UTC
This incident affected: Core Services (Hostinger Mail, Hostinger Mail API, Hostinger Webmail).