Free Mail service slow mail delivery
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Aug 20, 2020 - 16:05 UTC
Monitoring
Free mail service outbound queues have been reduced, and all emails sent in recent hours should soon reach destination points. Thank You for your patience.
Posted Aug 20, 2020 - 15:15 UTC
Identified
We have detected the main cause of increased delays in Free mail service deliverability and are actively trying to reduce the queue, that has formed in the process. We apologize for any inconveniences this may cause and please note, that all emails will be delivered, just with a delay. Thank You.
Posted Aug 20, 2020 - 13:58 UTC
Investigating
Some users might experience delays in mail delivery on Free mail service. We are working to reduce queues asap.
We will keep updating.
Posted Aug 20, 2020 - 13:00 UTC