Free Mail service slow mail delivery
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted May 05, 2020 - 15:16 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 05, 2020 - 14:01 UTC
Investigating
Some users might experience delays in mail delivery on Free mail service. We are working to reduce queues asap.
We will keep updating.
Posted May 05, 2020 - 13:47 UTC
This incident affected: Core Services (Email service).