Hostinger panel maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Oct 07, 2020 - 16:14 UTC
Investigating
There is currently an issue with hPanel order usage not being loaded properly and some users might be unable to examine their usage of resources.
Posted Oct 07, 2020 - 14:51 UTC
This incident affected: Core Services (Hostinger hPanel Frontend).