Increased Mail Queue
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Jul 23, 2021 - 07:32 UTC
Update
We are continuing to investigate this issue.
Posted Jul 23, 2021 - 07:11 UTC
Investigating
We are having issues with outgoing mail services. Outgoing emails are delayed. This is due SMTP service outage on MailChannels.
Apologies for any inconvenience.
Posted Jul 23, 2021 - 07:08 UTC
This incident affected: Email Hosting services (MailChannels service, Hostinger Mail SMTP Outbound).