Hostinger websites maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted May 13, 2020 - 04:29 UTC
Investigating
We are currently performing maintenance on main Hostinger websites. Visitors might experience interruptions loading our main websites.
Posted May 13, 2020 - 03:02 UTC
This incident affected: Core Services (Hostinger Website).