Server SG-179 Maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted May 11, 2021 - 05:02 UTC
Investigating
We are performing server SG-179 maintenance. Clients will experience service interruptions. We will provide further updates as necessary.
Posted May 11, 2021 - 02:51 UTC