Hostinger hPanel Maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Jul 12, 2020 - 13:31 UTC
Identified
There is currently an issue with loading hPanel email and order usage sections. Client websites are not effected and should be functioning normally. The issue is known and should be resolved shortly. Thank You for Your patience.
Posted Jul 12, 2020 - 12:26 UTC
This incident affected: Core Services (Hostinger Internal).