Hostinger.tld main page maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted May 22, 2020 - 14:02 UTC
Identified
We are currently performing maintenance on our main Hostinger webpages ( hostinger.tld websites ). hPanel and website services are not affected in any way. Sorry for any inconveniences that might arise and thank You for understanding.
Posted May 22, 2020 - 13:49 UTC
This incident affected: Core Services (Hostinger Websites).