Free Mail service maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted May 14, 2020 - 04:42 UTC
Update
We are continuing to investigate this issue.
Posted May 14, 2020 - 04:41 UTC
Investigating
Some users might be experiencing issues while login or sending emails from Webmail mail platform. We have detected the issue and are already working on a solution. Thank You for Your patience.
Posted May 14, 2020 - 04:27 UTC
This incident affected: Core Services (Email service).