HPANEL: Free Mail service maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Jun 18, 2020 - 09:16 UTC
Identified
We are performing Free Mail service maintenance in hPanel section. Some clients may experience service interruptions while using Hostinger Free Mail services.
Apologies for any inconvenience. Thank you for your patience.
Posted Jun 18, 2020 - 08:00 UTC