Domain registration issues
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Jan 24, 2023 - 20:33 UTC
Investigating
We are currently experiencing issues with domain registration. Our team investigating the issue and will update in the process.
Apologies for the inconvenience.
Posted Jan 24, 2023 - 13:12 UTC