Hostinger hPanel maintenance
Incident Report for Hostinger International
Resolved
The hPanel actions maintenance has been finished.
Posted 18 days ago. Aug 29, 2019 - 14:12 UTC
Identified
We are performing Hostinger hPanel maintenance. During this time certain actions on hPanel may take longer to execute than usual.

Customer websites are not affected and will be functionating properly.
Apologies for any inconveniences. Thank you for your patience.
Posted 18 days ago. Aug 29, 2019 - 11:44 UTC