Issue with one of Hostinger domain registrars
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Sep 26, 2021 - 06:54 UTC
Identified
We are currently having technical difficulties with one of our domain registrars. Clients may experience interruptions with domain registrations, renewals. We are communicating with the domain registrar and working on a solution as fast as possible.
Posted Sep 26, 2021 - 06:26 UTC