Hostinger Webmail maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Oct 26, 2020 - 14:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 26, 2020 - 14:14 UTC
Investigating
Some users might be experiencing issues while logging-in via Webmail. We have detected the issue and are already working on a solution. Thank You for Your patience
Posted Oct 26, 2020 - 14:01 UTC
This incident affected: Core Services (Hostinger Mail).