Free Mail service maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted May 27, 2020 - 14:24 UTC
Identified
Some users might be experiencing issues while logging-in, sending or receiving emails via Webmail mail platform due to increased queue sizes. We have detected the issue and are already working on a solution. Thank You for Your patience
Posted May 27, 2020 - 13:58 UTC