Free Mail service maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Apr 01, 2020 - 15:02 UTC
Identified
We are performing Free Mail service maintenance. Some clients may experience service interruptions while using Hostinger Free Mail services.
Apologies for any inconvenience. Thank you for your patience.
Posted Apr 01, 2020 - 12:45 UTC