Free Mail service maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Oct 12, 2020 - 07:01 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 12, 2020 - 06:33 UTC
Investigating
We are performing Free Mail service maintenance. Some clients may experience service interruptions while using Hostinger Free Mail services.
Apologies for any inconvenience. Thank you for your patience.
Posted Oct 12, 2020 - 06:04 UTC
This incident affected: Core Services (Hostinger Mail).