Emergency Server US-899 Maintenance

Incident Report for Hostinger

Resolved

The incident has been fixed.
Posted Sep 18, 2026 - 01:23 UTC

Monitoring

We pushed a fix to the incident and are monitoring the results.
Posted Sep 18, 2026 - 00:55 UTC

Investigating

We are performing an emergency maintenance on server 899, located in the US. Client websites hosted there could be temporarily inaccessible or might load slower than usual. Our team is currently working to restore normal performance levels. We apologize for any inconvenience caused.
Posted Sep 18, 2026 - 00:23 UTC