Free mail service maintenance
Incident Report for Hostinger International
Resolved
The issue has been resolved.
Posted Oct 16, 2019 - 19:55 UTC
Identified
We are having issues with free mail services. Outgoing and incoming emails might have a delay. Our engineers are working on a fix.
We expect degraded performance for the next 1-2 hours. We will update status as soon issue will be resolved. Apologies for any inconvenience.
Posted Oct 16, 2019 - 19:36 UTC