Email emergency maintenance in UK

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Jun 20, 2025 - 15:37 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 20, 2025 - 14:05 UTC

Monitoring

Email services are now operational following the earlier disruption. We are currently monitoring the system to ensure continued stability and performance.
Posted Jun 20, 2025 - 14:05 UTC

Investigating

We’re investigating an issue preventing access to email services in the UK-FAST datacenter. Users may be unable to send or receive emails while we work to resolve the issue.
We apologize for the inconvenience caused.
Posted Jun 20, 2025 - 13:34 UTC
This incident affected: Hostinger Email (Hostinger Mail).