.BLOG registry connection issues

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 12:22 UTC

Investigating

We are currently experiencing issues with .BLOG domains registry that might directly impact our users who are trying to purchase/register/manage an .BLOG domain. We are investigating the issue. Thank You for Your patience.
Posted Apr 25, 2025 - 06:27 UTC