Free Mail service slow mail delivery
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Sep 22, 2020 - 15:17 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2020 - 14:37 UTC
Investigating
We have detected the main cause of increased delays in Free mail service deliverability and are actively trying to reduce the queue, that has formed in the process. We apologize for any inconveniences this may cause and please note, that all emails will be delivered, just with a delay. Thank You.
Posted Sep 22, 2020 - 14:17 UTC
This incident affected: Email Hosting services (Hostinger Mail).