Server US-141 maintenance
Incident Report for
Hostinger
Resolved
This incident has been resolved.
Posted
May
20
,
2022
-
15:20
UTC
Update
We are continuing to investigate this issue.
Posted
May
20
,
2022
-
15:20
UTC
Investigating
We are performing scheduled server maintenance. Clients will experience up to 60-minute long Service interruptions. We will provide further updates as necessary.
Posted
May
20
,
2022
-
10:09
UTC
×
Subscribe to Incident
Subscribe to updates for
Server US-141 maintenance
via . You'll receive .