DNS Propagation Issue Affecting External Domains

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Sep 26, 2025 - 05:03 UTC

Investigating

We are currently investigating an issue with DNS propagation for external domains pointing to our DNS. This may cause some websites to be inaccessible from certain locations. Our team is working with upstream providers to identify the root cause.
Posted Sep 26, 2025 - 04:40 UTC
This incident affected: Core Services (Hostinger hPanel Backend, Hostinger hPanel Frontend).