.SHOP domain registration issues
Incident Report for
Hostinger
Resolved
This incident has been resolved.
Posted
Jun
04
,
2025
-
09:08
UTC
Investigating
We are currently experiencing connection issues with .SHOP domains. Registrations and transfers may be delayed during this time. Our team is actively working to resolve the issue as quickly as possible. Thank You for Your patience.
Posted
Jun
04
,
2025
-
07:40
UTC
×
Subscribe to Incident
Subscribe to updates for
.SHOP domain registration issues
via . You'll receive .