Website Builder Sites fails to restore

Incident Report for Hostinger

Resolved

Website restoration is back to normal.
Posted Jul 02, 2026 - 19:05 UTC

Identified

We have identified the issue and are fixing it.
Posted Jul 02, 2026 - 18:36 UTC
This incident affected: Hostinger Website Builder (Editor, User sites).