Server LT-1383 maintenance

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Jun 24, 2026 - 02:25 UTC

Monitoring

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Jun 24, 2026 - 02:11 UTC

Investigating

We are performing scheduled maintenance. Clients may experience service interruptions. We will provide further updates as necessary
Posted Jun 24, 2026 - 01:26 UTC