Free mail service incoming emails delay
Incident Report for Hostinger International
Resolved
This incident has been resolved.
Posted Aug 05, 2019 - 16:36 UTC
Monitoring
We have identified and fixed the issues with incoming emails delay. Queue is decreasing and we are monitoring results
Posted Aug 05, 2019 - 15:43 UTC
Identified
We are having issues with free mail services. Incoming emails might a delay, Our engineers are working on a fix.
We expect degraded performance for the next 2-3 hours. We will update status as soon issue will be resolved. Apologies for any inconveniences.
Posted Aug 05, 2019 - 15:10 UTC
This incident affected: E-mail Service (Incoming E-mail).