No issues were detected during cloudflare connectivity issues.
Posted Dec 19, 2025 - 17:21 UTC
Monitoring
No issues were detected, we are monitoring the results.
Posted Dec 19, 2025 - 16:29 UTC
Investigating
We’ve identified a third-party connectivity issue. Minimal service impact has been observed at this time. We’re working with the provider to mitigate the impact and will share updates as they become available. We apologize for any inconvenience caused
Posted Dec 19, 2025 - 15:38 UTC
This incident affected: Hostinger Website Builder (Editor) and Core Services (Billing System, Hostinger Websites, Payment services).