We've identified that our shared email account hsend.ai has been blocked. Our team is working to restore emails functionality. We apologize for the inconvenience caused.
Posted Apr 03, 2026 - 19:20 UTC
Investigating
We’re investigating a service disruption affecting users on the Hostinger Horizons platform. Our team is working to identify the cause and restore emails functionality. We apologize for the inconvenience caused.
Posted Apr 03, 2026 - 18:54 UTC
This incident affected: Hostinger Horizons (Hostinger Horizons Editor).