Site Builder maintenance
Incident Report for Hostinger International
Resolved
This incident has been resolved.
Posted Oct 03, 2019 - 10:01 UTC
Identified
We are performing Site Builder maintenance. During this time, the Site Builder section is not available.
Customer websites are not affected and will be functionating properly.
Apologies for any inconvenience. Thank you for your patience.
Posted Oct 03, 2019 - 08:55 UTC