Degraded website accessibility on Server h5g-node25 for temporary domains

Incident Report for Hostinger

Resolved

All websites are functional and the issue has been solved.
Posted Mar 27, 2026 - 21:41 UTC

Update

We identified an issue that affects all temporary domains on node25. Our team is working on the fix. Websites with a pointing domain are not affected
Posted Mar 27, 2026 - 20:49 UTC

Identified

We've identified the issue, a fix is being implemented.
Posted Mar 27, 2026 - 20:16 UTC

Investigating

We are currently experiencing Degraded website accessibility on Server h5g-node25 for temporary domains , located in the US. Client websites hosted there could be temporarily inaccessible or might load slower than usual. Our team is currently working to restore normal performance levels. We apologize for any inconvenience caused.
Posted Mar 27, 2026 - 17:52 UTC