hPanel email section maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Aug 14, 2020 - 14:10 UTC
Identified
We are currently performing maintenance on email accounts management page in hPanel. Some clients may experience service interruptions while trying to manage their email accounts using hPanel interface.
Apologies for any inconveniences. Thank you for your patience.
Posted Aug 14, 2020 - 12:47 UTC