We are continuing to work on resolving performance issues affecting servers. Remediation is ongoing, and we will provide additional updates as progress is made.
Posted Mar 12, 2026 - 22:37 UTC
Update
A small number of servers are still experiencing degraded performance. We are manually investigating these systems and will provide further updates as needed.
Posted Mar 12, 2026 - 21:04 UTC
Update
Services should now be operating normally. We will continue monitoring for any further issues.
Posted Mar 12, 2026 - 20:46 UTC
Update
We have deployed a fix and it is currently rolling out across the infrastructure. Service stability should gradually improve over the next 10–20 minutes as the deployment completes.
Posted Mar 12, 2026 - 20:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 12, 2026 - 18:34 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 12, 2026 - 18:27 UTC
Investigating
We are currently experiencing degraded performance issues on some servers. Websites could be temporarily inaccessible or might load slower than usual. Our team is currently working to restore normal performance levels. We apologize for any inconvenience caused.