Hostinger Horizons Downtime

Incident Report for Hostinger

Resolved

The issue has been fixed.
Posted Jan 27, 2026 - 13:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 27, 2026 - 12:58 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 27, 2026 - 12:56 UTC

Investigating

We’re investigating a service disruption affecting users on the Hostinger Horizons platform for live websites. Our team is working to identify the cause and restore normal operations as quickly as possible. We apologize for the inconvenience caused.
Posted Jan 27, 2026 - 12:54 UTC
This incident affected: Hostinger Horizons (Hostinger Horizons Editor, Hostinger Horizons Preview) and Core Services (Hostinger Websites).